Trip to Krabi, Thailand

Trip to Krabi, Thailand

      One of my dream place in my bucket travel list is Krabi Thailand, of course how can anyone would not love...

Photowalk at Singapore Chinese Garden

Photowalk at Singapore Chinese Garden

      One of the places that you should take a visit when you are here in Singapore is the Chinese Garden....

Photowalk at Changi Beach Park Singapore

Photowalk at Changi Beach Park Singapore

      Last May 13 it was Mother's day and the weather was great for photowalking. So my wife and I decided to...

Trip to Jurong Bird Park Singapore

Trip to Jurong Bird Park Singapore

        One of the most common tourist spot in Singapore is Jurong Bird Park which has almost 5000 birds of...

Trip to Sentosa Island Singapore

Trip to Sentosa Island Singapore

      It's my wifey's birthday and I don't know how to cook :) what I did is to figure out what's the best...

Trip to Universal Studios Singapore

Trip to Universal Studios Singapore

      Finally I got the chance to go in Universal Studios Singapore with my wife.  I heard a lot of fun stories...

Trip to Kuala Lumpur

Trip to Kuala Lumpur

           I never thought that Chinese New Year (CNY) was really a great holiday to wait here in...

  • Trip to Krabi, Thailand

    Trip to Krabi, Thailand

  • Photowalk at Singapore Chinese Garden

    Photowalk at Singapore Chinese Garden

  • Photowalk at Changi Beach Park Singapore

    Photowalk at Changi Beach Park Singapore

  • Trip to Jurong Bird Park Singapore

    Trip to Jurong Bird Park Singapore

  • Trip to Sentosa Island Singapore

    Trip to Sentosa Island Singapore

  • Trip to Universal Studios Singapore

    Trip to Universal Studios Singapore

  • Trip to Kuala Lumpur

    Trip to Kuala Lumpur

You are here: HomeTechiesBorder Gateway Protocol(BGP) routes to IGP

Border Gateway Protocol(BGP) routes to IGP

     

 

This is the configuration that I'd done during in our laboratory regarding on Border Gateway Protocol (BGP). Basically this configuration will give you an BGP routes be a part of the IGP route. Of course this configuration is configured in the Border Gateway of Autonomous System (AS). Below is the configuration, I will try to explain every details of the configuration.

 

 

router eigrp 200
redistribute bgp metric 10000 100 255 1 1500
passive-interface Serial0/0
network 192.168.1.0
network 192.168.100.0
network 192.168.214.0
no auto-summary
!
router bgp 200
bgp log-neighbor-changes
network 192.168.1.216 mask 255.255.255.252
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.226 remote-as 100
!

Within the AS 200, the EIGRP is the IGP that runs within the AS. The router BGP runs in the AS, You must be aware that this BGP is the one responsible for communicating inter-AS, although there are other ways to do the inter-AS communication but still the BGP is the best choice. Choices like redistribution is not good enough b'coz it provides alot deficiency just like route feedback. But I'm not going to promote BGP hehe it always still depends on the kind of networks you are running.

 

The redistribute bgp metric 10000 100 255 1 1500 in the EIGRP process is the key points in injecting BGP routes into an IGP. Basically, the routes in the BGP table is being redistributed into the IGP tables. One important point to consider whendoing the redistribution is metric of the IGP being used in the domain. Just like in my configuration whereas I'd used the EIGRP as my IGP within the domain.

 

You need to take note of the metric of the routing protocols, like EIGRP wherein it uses bandwidth,delay, realibility, load and MTU that's why bandwidth=10000, delay=100, reliability =255,load=1 and MTU=1500 in my configuration. To verify that routes from BGP is successfully injected to the IGP routes. Check the routing table of the routers within the AS and compare it to the BGP table in the border gateway.




 


You might also like:

              

Go to top